N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 29E0 and 2A2B, DME: Mixture Control. Log check? Bad precat o2s? - 08-02-2017, 10:07 AM

2009 335i, 78k miles. First time taking a log in this car, didn't really get a full pull but hopefully it will do. Car is FBO with d*****, inlets, and Fuel-it Stage 2 LPFP but never had this problem until now.

Can post some more normal driving logs if that's preferred. Also, is it possible to get stft/trim on both banks using jb4?

My best guess is the precat oxygen sensors are bad, previous owner ran a lot of E85 if that matters. I'm running straight 93 nowadays and on a stock backend flash.
Or boost/vacuum leak? I'm new to reading these logs but it does seem to be running kinda lean, nothing crazy though. I did have the intake manifold pulled up enough to do the alternator recently and the codes showed up shortly after. Seems to run fine to me though.
Attached Files
File Type: csv gg.csv (11.7 KB, 9 views)
File Type: csv 3rdgearpull.csv (13.4 KB, 7 views)

Last edited by nissubaru; 08-03-2017 at 04:09 PM.. Reason: Attached logs
Reply With Quote
(#2)
Old
Dave @ Fuel-it!'s Avatar
Dave @ Fuel-it! Dave @ Fuel-it! is offline
Senior Member
 
Posts: 854
Join Date: Apr 2014
Car: E92 335XI
Default 08-02-2017, 08:16 PM

Please post the CSV file.

Thanks



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Pure Turbos
TFT Inlet System
Fueling by Fuel-It!
Reply With Quote
(#3)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-02-2017, 08:50 PM

https://drive.google.com/open?id=0B4...DVVNmc4RWpFOGc
Reply With Quote
(#4)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-03-2017, 10:41 AM

Another log, sorry I'm not pulling all the way to redline. Need a better spot for logging.

https://drive.google.com/file/d/0B4i...ew?usp=sharing




Also, having trouble with the JB4 program a little bit... For some reason I'm not getting any values on AFR2. And I also cannot get 6-cyl logging even though I have it set to "5" for IJE0S.

I was going to update my firmware but received the Firmware Mismatch message stating I would have to send my board into BMS to be flashed. Not really sure why because I'm pretty certain its a G5 ISO board (current firmware version = 27/5//2)...Do I really need to send it in? Thanks
Reply With Quote
(#5)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 17,055
Join Date: Oct 2012
Car: 135i
Default 08-03-2017, 12:53 PM

Please upload the CSV file to this website.

Sounds like you may be running an old board, firmware, or ???

Get that CSV file uploaded and we'll check it out.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#6)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-03-2017, 01:05 PM

Attached now, sorry I didn't see the attachment option on the bottom of the reply form.

Like 99% certain I'm running a JB4 G5 ISO board. Previous owner purchased and installed but my firmware is version = 27/5//2 which as far as I can tell the //2 designates ISO. Was there such a thing as G4 ISO? Do I gotta open the enclosure to know for sure?

Thanks
Attached Files
File Type: csv 3rdgearpull.csv (13.4 KB, 8 views)
File Type: csv gg.csv (11.7 KB, 6 views)
Reply With Quote
(#7)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 17,055
Join Date: Oct 2012
Car: 135i
Default 08-03-2017, 04:28 PM

That is a G5 board but the diodes may not be cut. You'd need to open it up and take a picture of the board for us to know for sure.

You'll need to update the firmware either way as that is extremely outdated.

Leave it on map 0 and post a pic. Then we can go from there.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#8)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-03-2017, 05:15 PM

I texted the previous owner who is/was a member on these forums and he said it's a G5 ISO board for sure. Curious why I can't get the firmware to update then? Terry said in another thread:

Quote:
Originally Posted by Terry @ BMS
Exactly. You send the board in and we flash the latest firmware to it. Those who update at home would never use this. The one caveat being older JB4 boards have some fuses on the chip that can only be set at flash time. Some day we may add features that requires those fuses to be set a certain way so in that case older boards would need to be sent in to be flashed using this option.
Shouldn't I be okay? Either way, I'm most curious about the logs and why I'm throwing these codes if anything sticks out to you that'd be much appreciated. I don't see anything that seems out of the ordinary but I'm very new to this

Thank you
Reply With Quote
(#9)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-04-2017, 05:42 AM

Put it in map 5 and cleared the codes, but the car never got rid of the lights on the dash? From my amateur viewpoint this looks like my afr's are lean and I'm not hitting my target boost, and its building slowly. Boost leak?

I recently did the alternator and had the intake manifold pulled back with the diverter valves removed to make room (they kept hitting the fender, also has the fuel it throttle body injection installed but it's unplugged since I'm not running any e85).
Attached Files
File Type: csv dd.csv (3.8 KB, 6 views)

Last edited by nissubaru; 08-04-2017 at 07:26 AM..
Reply With Quote
(#10)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 17,055
Join Date: Oct 2012
Car: 135i
Default 08-04-2017, 05:11 PM

You can send the board in to be flashed. You'll definitely need to update your firmware.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#11)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-04-2017, 05:30 PM

Why would I have to send it in if it's a G5 Iso board?
Reply With Quote
(#12)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 17,055
Join Date: Oct 2012
Car: 135i
Default 08-06-2017, 03:40 PM

If you can't flash it, then you have the option to send it in to be flashed. Either way, it's needs to be flashed.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#13)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-06-2017, 03:50 PM

My question was more regarding why this message is popping up if I should be able to update on my own. I have the BMS usb cable and all the technical know how necessary but as soon as I connect the car within JB4 and hit "Update firmware" I get the message telling me I need to send it in.

Do I need to roll back to an earlier interface version first? Thank you for your reply.

As for the logs, I'm going to replace the primary o2s and see if that gets rid of the codes
Reply With Quote
(#14)
Old
dsrugis dsrugis is offline
Junior Member
 
Posts: 41
Join Date: Mar 2014
Car: BMW M3
Default 08-09-2017, 10:54 AM

Did you ever solve this?
Reply With Quote
(#15)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-09-2017, 10:59 AM

Not yet, the new primary o2 sensors should have been delivered today. Gonna attempt this either Friday or Saturday. Also I'll be taking off the ********* and putting on stock ones but I don't believe that's the problem. Will update if code goes away
Reply With Quote
(#16)
Old
dsrugis dsrugis is offline
Junior Member
 
Posts: 41
Join Date: Mar 2014
Car: BMW M3
Default 08-09-2017, 11:06 AM

Quote:
Originally Posted by nissubaru
Not yet, the new primary o2 sensors should have been delivered today. Gonna attempt this either Friday or Saturday. Also I'll be taking off the ********* and putting on stock ones but I don't believe that's the problem. Will update if code goes away
Thanks...my car is having identical issues right now with same codes. If not, 02, I'm thinking injectors.
Reply With Quote
(#17)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 17,055
Join Date: Oct 2012
Car: 135i
Default 08-09-2017, 08:38 PM

If you can't upload the firmware you won't be able to roll it back nor is it necessary.

Frankly no answer you want to hear...if you can't upload the firmware you need to send it in, just as there error says.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#18)
Old
nissubaru nissubaru is offline
Junior Member
 
Posts: 36
Join Date: Jun 2017
Car: 2009 335i M-Sport
Default 08-12-2017, 08:25 PM

Quote:
Originally Posted by dsrugis
Did you ever solve this?
Pre *** o2s seemed to be the fix
Reply With Quote
(#19)
Old
dsrugis dsrugis is offline
Junior Member
 
Posts: 41
Join Date: Mar 2014
Car: BMW M3
Default 08-13-2017, 06:05 AM

Quote:
Originally Posted by nissubaru
Pre *** o2s seemed to be the fix
Cool...I bought a used one for $15 for diagnosis purposes. We'll see if it fixed it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2017, N54tech.com