N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default Jb4 G5 Resetting Itself - 09-12-2017, 03:03 AM

My G5 keeps resetting itself whenever I get on the throttle, the signals blink and it goes from any selected map to map 1. Even when it's set to disabled on map 0 it will blink back to map 1.


Codes:
2ABC - Charging pressure sensor, electrical
2ABD - Intake pressure sensor, re-running
29F3 - Fuel pressure sensor, electrical

These codes cause a cel and engine malfunction, is this why the G5 keeps resetting?
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 21,715
Join Date: Jan 2008
Default 09-12-2017, 07:40 AM

Something else out on CANbus? JB4 log?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default 09-12-2017, 09:02 AM

Quote:
Originally Posted by Terry @ BMS
Something else out on CANbus? JB4 log?
I can log later today, nothing but jb4 is connected. Single turbo setup MHD flashed
Reply With Quote
(#4)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 21,715
Join Date: Jan 2008
Default 09-12-2017, 09:46 AM

Single turbo going to map1 is a safety system... That is probably what is happening here, not a board reset.

Log will tell us why.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#5)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default 09-12-2017, 01:40 PM

Quote:
Originally Posted by Terry @ BMS
Single turbo going to map1 is a safety system... That is probably what is happening here, not a board reset.

Log will tell us why.
Log uploaded. Also the interface says the last safety was AFR Lean.
Attached Files
File Type: csv 170912_1630.csv (32.9 KB, 4 views)
Reply With Quote
(#6)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 21,715
Join Date: Jan 2008
Default 09-12-2017, 02:02 PM

Is it! Something looks messed up here starting with the flash end. You loaded a normal BEF map?
Attached Images
 


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#7)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default 09-12-2017, 02:05 PM

Quote:
Originally Posted by Terry @ BMS
Is it! Something looks messed up here starting with the flash end. You loaded a normal BEF map?
I loaded the newest ST map using MHD. Write took 2 minutes. Is this correct or should I reflash?

Edit: Car also dies when the Jb4 is enabled on start up.

Last edited by Ancient8989; 09-12-2017 at 02:25 PM..
Reply With Quote
(#8)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 16,249
Join Date: Oct 2012
Car: 135i
Default 09-12-2017, 10:22 PM

This is a mess!

You did a full write and were flashing for the first time or it was an update?

Your LPFP sensor is bad.

HPFP is very low.

AFR's are extremely lean.

Bank to bank AFR's have a pretty big delta.

Trims are maxing out.

You have some work to do.

2ABC and 2ABD can definitely be contributing to this as well.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#9)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default 09-13-2017, 05:57 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
This is a mess!

You did a full write and were flashing for the first time or it was an update?

Your LPFP sensor is bad.

HPFP is very low.

AFR's are extremely lean.

Bank to bank AFR's have a pretty big delta.

Trims are maxing out.

You have some work to do.

2ABC and 2ABD can definitely be contributing to this as well.
It was an update to the flash. Also somehow I messed something up while flashing. Car cranks forever and starts, but throws every error under the sun. Specifically 2FA3 DME no coding. I've flashed it back to stock on a long write using MHD and everything. Same thing. Jb4 was completely removed during stock flash, and set to map 0 on the ST reflash. I don't know what to do about it.
Reply With Quote
(#10)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 16,249
Join Date: Oct 2012
Car: 135i
Default 09-13-2017, 08:11 AM

Try contacting MHD. Sounds like you will need a full write and may need to interrupt an upload to start fresh.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#11)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default 09-13-2017, 02:16 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Try contacting MHD. Sounds like you will need a full write and may need to interrupt an upload to start fresh.
Reflashed to stock and the crankshaft position sensor came unplugged so car starts just fine. Doing a full write ST flash at the moment. Do you think replacing sensors will help all the fuel related symptoms if a reflash doesn't?
Reply With Quote
(#12)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 21,715
Join Date: Jan 2008
Default 09-13-2017, 02:34 PM

Quote:
Originally Posted by Ancient8989
It was an update to the flash. Also somehow I messed something up while flashing. Car cranks forever and starts, but throws every error under the sun. Specifically 2FA3 DME no coding. I've flashed it back to stock on a long write using MHD and everything. Same thing. Jb4 was completely removed during stock flash, and set to map 0 on the ST reflash. I don't know what to do about it.
What is the DME software version?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#13)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default 09-13-2017, 07:18 PM

The DME was successfully flashed to stock and reflashed using the newest version of the ST map for my car. Performance seems improved by a mile. I will run a log tomorrow, it's been rainy today.
Reply With Quote
(#14)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 21,715
Join Date: Jan 2008
Default 09-13-2017, 07:27 PM

Ok fingers crossed.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#15)
Old
Ancient8989 Ancient8989 is offline
New Member
 
Posts: 12
Join Date: Aug 2017
Car: 335i
Default 09-14-2017, 01:36 PM

Quote:
Originally Posted by Terry @ BMS
Ok fingers crossed.
Here's a log from today map 2 pull, obvious boost leak, not sure what else.

FF set to 20, adapted to 42
DWP set to 20
Duty Bias set to 50
Attached Files
File Type: csv 170914_1624.csv (16.9 KB, 2 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2017, N54tech.com