N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1)
Old
5Dirty5's Avatar
5Dirty5 5Dirty5 is offline
Junior Member
 
Posts: 58
Join Date: Apr 2015
Car: 2008 BMW 535I
Default Car feels unsafe on freeway excessive sway - 01-31-2018, 03:53 PM

2008 BMW 535 with sport package, a few weeks ago had a warning light on the dash about dynamic stability control, pulled up at the house check the power steering fluid noticed it was low so I topped it off, ever since then the car feels unsafe on the freeway At speeds above 65 miles an hour excessive swaying back-and-forth the car literally feels like the sway bars are disconnected.has anybody dealt with this issue? Literally have the same sensation as being blown around in the wind, and forget sudden lane changes, as they’ll make your butt hole pucker
Reply With Quote
(#2)
Old
zipphreak zipphreak is offline
Junior Member
 
Posts: 92
Join Date: Jun 2015
Car: 2015 BMW m235xi
Default 02-02-2018, 04:29 PM

Your car is getting old.. 10 years.. Have you ever serviced the struts? Checked the control arm/tie rod ball joints? Struts don't last forever. Best to check everything, or have someone familiar do a full inspection. There is no wizbang answer most of it involves some physical work to get in there and check out your car


2015 BMW m235xi (F22/N55/EWG) | JB4 + BEF | Wagner Evo2 Performance IC | ER Chargepipe | K&N Dropin | Ground-Control v2 Camber Plates | Dinan Springs | HPA Adjustable Sway Bar Links
VMR V710's | Front 18x8.5 ET45 (235/40/18) | Rear 18x9.5 (265/35/18) | Hankook RS4
https://www.youtube.com/watch?v=dUvs...ature=youtu.be
Reply With Quote
(#3)
Old
5Dirty5's Avatar
5Dirty5 5Dirty5 is offline
Junior Member
 
Posts: 58
Join Date: Apr 2015
Car: 2008 BMW 535I
Default 02-03-2018, 08:57 AM

This is something that happened instantly. My car has dynamic drive, and active steering so I’m guessing one or both of these are offline at the moment
Reply With Quote
(#4)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 914
Join Date: Jun 2011
Car: 135i N54
Default 02-05-2018, 09:42 AM

Is anything leaking from the dynamic drive / active sways? Common problem unfortunately on 5'er.

Sure the fluid reservoir is fully sealed after you opened it? Has it dropped again since you filled it?
Reply With Quote
(#5)
Old
LessIsMore's Avatar
LessIsMore LessIsMore is offline
Inner Circle Member
 
Posts: 935
Join Date: Aug 2012
Car: 2009 535i Sport SAT
Default 02-08-2018, 09:53 AM

Did your warning light go away or still on? Any codes stored?

It might require a module reset or ISTA diagnosis. A BMW indy shop should be able to do it easily.

Physically, look for leaks from ARS lines, and at the ARS elec motor. And keep a close eye on fluid.


2009 535i Sport - 548whp
Software :
JB4 G5 | MHD | Trebila Tune | XHP Stage 3
Hardware: VTT GC Lites | MFactory Helical LSD | Inlets | Outlet | VRSF 3" D-P's | VRSF 7" FMIC | Fuel-It! S2 LPFP | Fuel-It! TBI | BMS DCI | ER CP | Forge DV's | Koni FSD

Reply With Quote
(#6)
Old
5Dirty5's Avatar
5Dirty5 5Dirty5 is offline
Junior Member
 
Posts: 58
Join Date: Apr 2015
Car: 2008 BMW 535I
Default 02-08-2018, 11:50 AM

No the warning light only came on briefly as I was making a right hand turn, as far as leaks it’s hard to tell because currently I’m attacking all of the OIL leaks that this car is plagued with. So engine is pulled apart doing front crank seal, both oil cooler gaskets, valve cover gasket, and I’m going to do a walnut shelling on the intake valves while I have it all opened up

Last edited by 5Dirty5; 02-08-2018 at 05:17 PM..
Reply With Quote
(#7)
Old
LessIsMore's Avatar
LessIsMore LessIsMore is offline
Inner Circle Member
 
Posts: 935
Join Date: Aug 2012
Car: 2009 535i Sport SAT
Default 02-08-2018, 06:14 PM

should be even easier then!

if no leaks and/or fluid level is not dropping, hook ISTA up to it and run a diag on the ARS/PS system and modules.


2009 535i Sport - 548whp
Software :
JB4 G5 | MHD | Trebila Tune | XHP Stage 3
Hardware: VTT GC Lites | MFactory Helical LSD | Inlets | Outlet | VRSF 3" D-P's | VRSF 7" FMIC | Fuel-It! S2 LPFP | Fuel-It! TBI | BMS DCI | ER CP | Forge DV's | Koni FSD

Reply With Quote
(#8)
Old
5Dirty5's Avatar
5Dirty5 5Dirty5 is offline
Junior Member
 
Posts: 58
Join Date: Apr 2015
Car: 2008 BMW 535I
Default 02-08-2018, 06:22 PM

Sorry but I don’t have ISTA I’ve heard of it but I haven’t downloaded it or used it yet
Reply With Quote
(#9)
Old
5Dirty5's Avatar
5Dirty5 5Dirty5 is offline
Junior Member
 
Posts: 58
Join Date: Apr 2015
Car: 2008 BMW 535I
Default 02-18-2018, 06:10 PM

Quote:
Originally Posted by LessIsMore
should be even easier then!

if no leaks and/or fluid level is not dropping, hook ISTA up to it and run a diag on the ARS/PS system and modules.
I finally got ISTA installed and running. How can I run a diag on the ARS/PS?
Reply With Quote
(#10)
Old
5Dirty5's Avatar
5Dirty5 5Dirty5 is offline
Junior Member
 
Posts: 58
Join Date: Apr 2015
Car: 2008 BMW 535I
Default 02-18-2018, 06:21 PM

Anyone know how to use ISTA-D??
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2017, N54tech.com