N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1)
Old
Nikita147 Nikita147 is offline
New Member
 
Posts: 5
Join Date: Mar 2018
Car: bmw 340 MT
Angry JB4 + Security Kit = Check Engine - 03-02-2018, 09:47 PM

Hi
I installed JB4 as per instruction, but I have security pack that listen to the radio channel and activate OBD-II socket when it is authorized with additional radio security key.
So OBD-II is activated usually ~10 seconds before I press "Start engine" and deactivated when I lock the car with car key.

JB4 with this config works fine about 2-3 days, but on the 3rd day JB4 activate Check engine light with "108005 No Description Found" error.

I think it happens because JB4 is should be always online and count OBD-II connection errors and when it has more than 5 error it activate CE.

Is there any option to update JB4 software in order to manage this configuration?

thanks.
Nikita
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 24,700
Join Date: Jan 2008
Default 03-03-2018, 09:57 AM

What firmware version are you running exactly?

Update it to the latest and see if that helps.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
Nikita147 Nikita147 is offline
New Member
 
Posts: 5
Join Date: Mar 2018
Car: bmw 340 MT
Default 03-06-2018, 12:00 PM

Quote:
Originally Posted by Terry @ BMS
What firmware version are you running exactly?

Update it to the latest and see if that helps.
I have Firmware version 58/8//5. Is is the latest one?

Looks like it is version 8.
In forum I found two firmwares: BMW_B48_B58_OBDII_8 and BMW_B48_B58_OBDII_8_T12. What is the difference between them?
Sorry, I tried to search it but didn't found.
Reply With Quote
(#4)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 24,700
Join Date: Jan 2008
Default 03-06-2018, 12:03 PM

There are various subversions posted.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#5)
Old
Nikita147 Nikita147 is offline
New Member
 
Posts: 5
Join Date: Mar 2018
Car: bmw 340 MT
Default 03-09-2018, 12:48 AM

I updated to the latest version BMW_B48_B58_OBDII_8.
Still the same issue: after 5-6 trips I see CE light on the panel with the same error "108005 No Description Found".
Reply With Quote
(#6)
Old
Nikita147 Nikita147 is offline
New Member
 
Posts: 5
Join Date: Mar 2018
Car: bmw 340 MT
Default 03-22-2018, 01:50 AM

I updated to BMW_B48_B58_OBDII_9_T4.hex.
Unfortunately have the same issue - I have CE after 5-8 trips. Any other options to manage it?
Reply With Quote
(#7)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,426
Join Date: Oct 2012
Car: 135i
Default 03-22-2018, 10:17 AM

You can not have anything else in the OBDII port and need the JB4 OBDII cable installed.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#8)
Old
Nikita147 Nikita147 is offline
New Member
 
Posts: 5
Join Date: Mar 2018
Car: bmw 340 MT
Default 04-04-2018, 12:54 AM

I dont have anything else in OBD port except JB4 . The only difference with stock is that OBD port is disconnected (signal or power pin) when car is locked and connected back when I unlock the car and security RF-token is in the close area.
I would assume that this error "108005 No Description Found" is produced by JB4 and it is because JB4 sense that it was just connected to the car.
Reply With Quote
(#9)
Old
SSIMPS SSIMPS is offline
New Member
 
Posts: 2
Join Date: Mar 2018
Car: X3 M40i
Default 05-02-2018, 12:30 PM

I am also seeing this same error. I took the JB4 off for a service and reinstalled it and began seeing this code about a week later for the first time. It also won’t clear.

I am not seeing reduced power, just a CEL

Updated firmware to V9T4 and same result

Edit: I had been running the JB4 for about 2 months previously and the only difference I can think of is the dealer updated the iDrive software, crashed it in the process and had to reprogram the car. I had previously had Almaretto code the car so OBD alarm was off if that could make a difference...

Last edited by SSIMPS; 05-02-2018 at 12:53 PM.. Reason: Update
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2017, N54tech.com