N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1476)
Old
tlucasbr tlucasbr is offline
New Member
 
Posts: 10
Join Date: Oct 2016
Car: 2014 328i
Default 09-03-2017, 07:14 AM

Quote:
Originally Posted by Herc
you lost me! what do you mean firmware change log?.
A transcription of the modifications made to the firmware functions over releases/updates. Some call this change log.
Reply With Quote
(#1477)
Old
Herc Herc is offline
Junior Member
 
Posts: 181
Join Date: Nov 2016
Car: F20 125i
Default 09-03-2017, 09:32 AM

aaaa!! i think no. the latest update includes the water and trans temps
Reply With Quote
(#1478)
Old
tlucasbr tlucasbr is offline
New Member
 
Posts: 10
Join Date: Oct 2016
Car: 2014 328i
Default 09-03-2017, 12:46 PM

For those with the same issue
Jon told me that now the N20_TMAP value is enforced to be 1, and if set to 0 it would reset both settings... So I'm changing the BoostSafety only and leaving the N20_TMAP set to it's default. Not sure when that happened, seems to be after EWG_4.
Reply With Quote
(#1479)
Old
ROGERIOSPEED ROGERIOSPEED is offline
New Member
 
Posts: 8
Join Date: Aug 2017
Car: 125i M 2014
Default 09-06-2017, 03:22 PM

Hi everyone.

Anybody could tell me which JB4 model do I have? It just has TMAP,
MAP and FLEX-FUEL cables (old box- new board). It's connected on my 125i M F20 14'. Do I need the EWG cable? The JB4 is working in Map 5 seutp and it's running OK.

Tanks.

Roger
Reply With Quote
(#1480)
Old
seroga1986's Avatar
seroga1986 seroga1986 is offline
Junior Member
 
Posts: 397
Join Date: Nov 2012
Car: 135i
Default 09-07-2017, 11:32 AM

Im pretty sure its been covered many times. Im taking my X3 across country on a road trip. Will 91 octane be enough/safe to run on map2? Thanks


2008 135i Sport 6at
JB4 G5 ISO, MHD E85 KR, Fuel-it S1, E55 Mix, Alpina Trans Flash, afe Scoops, My own custom 2.5" inlets, ER CP, Synapse BOV, 3.5 Tmap, 7" V R S F FMIC, NGK 5992, 3" BMS downtubes, N55 Mids, Berk Race, BMS OCC, 48 plate oil cooler, 36 plate trans fluid cooler, PSS, R888, Hoosier DRs.
11.92@123.6 (JB4 ISO, DCI, IC, **, DR, on e45 & 17psi)(2013)
444whp/481wtq @19psi and e60 (2013)

2013 X3 xDrive28i M-package
JB4, K&N drop-in, ER **, Map 2 @ 22psi on 93
Reply With Quote
(#1481)
Old
Herc Herc is offline
Junior Member
 
Posts: 181
Join Date: Nov 2016
Car: F20 125i
Default 09-08-2017, 10:13 PM

Quote:
Originally Posted by ROGERIOSPEED
Hi everyone.

Anybody could tell me which JB4 model do I have? It just has TMAP,
MAP and FLEX-FUEL cables (old box- new board). It's connected on my 125i M F20 14'. Do I need the EWG cable? The JB4 is working in Map 5 seutp and it's running OK.

Tanks.

Roger
maps 3,5,6 and 7 require all cables to be connected. i had answer this to you some posts before not that difficult is straight forward. If you have more qs you can always refer to the first post on this thread with the instructions.
Reply With Quote
(#1482)
Old
supa supa is offline
New Member
 
Posts: 2
Join Date: Sep 2017
Car: 2014 BMW 328i Xdrive N20
Default 09-15-2017, 08:11 AM

Hi Terry or anyone,

I just recently purchased JB4 with Bluetooth connection Rev. 3 for my 2014 F30 328I xDrive N20 and I would like to know what is the latest firmware to update. Can anyone sent me the link so I update my firmware PLEASEE!!! I checked the first post and it shown T2.hax but some people said they are using T5.hax now but I cant seem to find them.

I also can not use SPEED TIMING function as well even though I did everything I suppose to, Calibrated G Force Meter, come to complete stop and waited till GPS speed reading 0. Still nothing happening.

Please help if anyone have ideas.

Thanks!!!
Reply With Quote
(#1483)
Old
Herc Herc is offline
Junior Member
 
Posts: 181
Join Date: Nov 2016
Car: F20 125i
Default 09-15-2017, 10:34 AM

No T5.hex exists . However EWG/PWG 5 T2 is the latest one. Always refer to the first post of this thread
Reply With Quote
(#1484)
Old
supa supa is offline
New Member
 
Posts: 2
Join Date: Sep 2017
Car: 2014 BMW 328i Xdrive N20
Smile 09-15-2017, 11:19 AM

Quote:
Originally Posted by Herc
No T5.hex exists . However EWG/PWG 5 T2 is the latest one. Always refer to the first post of this thread

Thank you Herc!! how about the SPEED TIMING? How come it doesn't seem to work for me?

Thanks
Reply With Quote
(#1485)
Old
Herc Herc is offline
Junior Member
 
Posts: 181
Join Date: Nov 2016
Car: F20 125i
Default 09-15-2017, 10:00 PM

No clue on the speed timing. G meter is a new feat so you may want to ask here: http://www.n54tech.com/forums/showthread.php?t=21742
Reply With Quote
(#1486)
Old
dargorbr's Avatar
dargorbr dargorbr is offline
New Member
 
Posts: 17
Join Date: Feb 2015
Car: wrx
Default 09-18-2017, 11:08 AM

does the n20 firmware supports boost duty bias adjustments?
Reply With Quote
(#1487)
Old
liveevil liveevil is offline
New Member
 
Posts: 24
Join Date: Sep 2016
Car: F34 320i
Default 09-18-2017, 05:22 PM

Quote:
Originally Posted by Herc
aaaa!! i think no. the latest update includes the water and trans temps
Thank Herc. Your posts have been helpful.

I can't seem to find the changes in the current version on page 1. Would you know them? (Just like how I can see the changes when I update app in the Apple Store?)
Reply With Quote
(#1488)
Old
Herc Herc is offline
Junior Member
 
Posts: 181
Join Date: Nov 2016
Car: F20 125i
Default 09-19-2017, 06:10 AM

No i dont. BMS has a rather strict policy for competition reasons, cant blame them.

From another conversation we assume that boost safety is raised to 24 from 23 as can be seen on the last pic of the 1st post.

we hope that an appointed member may provide some info
Reply With Quote
(#1489)
Old
Msportmadness's Avatar
Msportmadness Msportmadness is offline
Junior Member
 
Posts: 34
Join Date: Oct 2017
Car: 2014 328i
Default Oil temp not workimg - 10-09-2017, 01:21 PM

I've had the jb4 stage 2 for around 2 weeks now everything is perfect except that the oil temp does not work. Is not a bother, just wondering if this has happened to anyone and if there's an easy fix, i did upgrade to the latest software 2 days ago just in case but didn't work.
Reply With Quote
(#1490)
Old
matteis matteis is offline
New Member
 
Posts: 2
Join Date: Oct 2017
Car: BMW F30
Default 10-15-2017, 12:47 PM

I have a F30 328i 2014. I have been using JB4 EWG for 3 months with no issues until last week. Now, I am unable to change maps when pressing BC Button. When I press and hold BC, nothing happens.

Does anyone know how to solve this problem or my JB4 is dead?

Tks in advance.
Reply With Quote
(#1491)
Old
Herc Herc is offline
Junior Member
 
Posts: 181
Join Date: Nov 2016
Car: F20 125i
Default 10-15-2017, 01:20 PM

Do you have either the data cable or BT to connect to it..?

Oil temps are still under development and we await news. last hex added water and trans temps
Reply With Quote
(#1492)
Old
matteis matteis is offline
New Member
 
Posts: 2
Join Date: Oct 2017
Car: BMW F30
Default 10-15-2017, 01:58 PM

Quote:
Originally Posted by Herc
Do you have either the data cable or BT to connect to it..?
Hi, I don't know if this message is for me. If it is, I don't have BT or Data Cable connected. Why?
Reply With Quote
(#1493)
Old
Msportmadness's Avatar
Msportmadness Msportmadness is offline
Junior Member
 
Posts: 34
Join Date: Oct 2017
Car: 2014 328i
Default 10-15-2017, 06:08 PM

Quote:
Originally Posted by Herc
Do you have either the data cable or BT to connect to it..?

Oil temps are still under development and we await news. last hex added water and trans temps
I have the BT connected to it, i wasn't aware that the oil temps were still under development. Thats great. I do have the water and trans temp

Thank you.
Reply With Quote
(#1494)
Old
Herc Herc is offline
Junior Member
 
Posts: 181
Join Date: Nov 2016
Car: F20 125i
Default 10-15-2017, 11:22 PM

Yes matteis was refering to you at the first answer. my bad didnt wrote your name.
if you did and could connect and take a log, it would had helped. on the other hand when the BT is connected the BC control is not working...

Msportmadness the only tip and hint for the oilt temp till they resolve this is to enable the secret menu on the speedometer. Doing that though you loose any other standar info provided ie time gear etc. experience wise i have notice that oil and water most often they have similar temps +/- 5c deppending whats you driving mood. Further the cooling system is rather sufficient and in Greece with 38c, the temps did not exceed the 120c on full throttle. Coasting in either legal on non limits the temps are rather low. ie at 160km/h i get 105c with 110 if i hit an uphill

Last edited by Herc; 10-15-2017 at 11:33 PM..
Reply With Quote
(#1495)
Old
SlowMo SlowMo is offline
New Member
 
Posts: 4
Join Date: Oct 2017
Car: N20
Default 10-23-2017, 11:30 AM

Quote:
Originally Posted by matteis
I have a F30 328i 2014. I have been using JB4 EWG for 3 months with no issues until last week. Now, I am unable to change maps when pressing BC Button. When I press and hold BC, nothing happens.

Does anyone know how to solve this problem or my JB4 is dead?

Tks in advance.
your obd cable could have come loose.
Reply With Quote
(#1496)
Old
johntotah94 johntotah94 is offline
Junior Member
 
Posts: 47
Join Date: Mar 2016
Car: B46 F56S
Default 10-23-2017, 06:10 PM

How much E85 are you guys mixing with the N20?
Reply With Quote
(#1497)
Old
kazBm3's Avatar
kazBm3 kazBm3 is offline
New Member
 
Posts: 17
Join Date: Jun 2016
Car: F30 N20 328
Default Jb4 N20 Wiring Loom -EWG - 10-27-2017, 05:55 AM

Hey Terry ,

Couldn't find a replacement loom on the site .
Mine was damaged . Can you send me a link or some info on how to purchase a replacement wiring loom for the Jb4 N20 EWG ?
Reply With Quote
(#1498)
Old
Msportmadness's Avatar
Msportmadness Msportmadness is offline
Junior Member
 
Posts: 34
Join Date: Oct 2017
Car: 2014 328i
Default 10-27-2017, 06:00 AM

Quote:
Originally Posted by johntotah94
How much E85 are you guys mixing with the N20?
I have the jb4 with the flex wires connected, i just mixed 4 gallons of e85 and the rest 93oct a few days ago and you feel the difference right away. I uploaded logs and terry looked at them and said everything was fine but my flex wires weren't installed. I just noticed i didn't have them installed 2 days ago. I'll have to do another log and post them just to make sure.
Reply With Quote
(#1499)
Old
Matta Matta is offline
New Member
 
Posts: 8
Join Date: Jun 2017
Car: 320i 2013
Default 10-27-2017, 09:22 AM

Hi

I have a 2013 320i ewg with jb4 running map5, i feel that the power is a bit uneven, hesetates a bit some times. Power delivery is perfect smood when running stock, but not with jb4 map5.

Anyone experienced the same?
Reply With Quote
(#1500)
Old
Msportmadness's Avatar
Msportmadness Msportmadness is offline
Junior Member
 
Posts: 34
Join Date: Oct 2017
Car: 2014 328i
Default 10-27-2017, 09:28 AM

Quote:
Originally Posted by Matta
Hi

I have a 2013 320i ewg with jb4 running map5, i feel that the power is a bit uneven, hesetates a bit some times. Power delivery is perfect smood when running stock, but not with jb4 map5.

Anyone experienced the same?
I have a 328i ewg, i was told the n20/n26 even with e85 dont have the same kick as the n54's in map 5. To stick with map 2
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2017, N54tech.com