N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1)
Old
Kmastl Kmastl is offline
New Member
 
Posts: 13
Join Date: Aug 2017
Car: 2008 535i
Default Log review / shadow codes e60 535i - 03-20-2018, 09:21 PM

Hello,

I will try to keep this brief and to the point. I have a 2008 535i. I installed a JB4 yesterday. I was getting overboost issues (single hazard flash) starting last night, I was left semi-stranded when the HPFP wouldn't build pressure (today). Rail pressure was > 100... I believe it was tune/jb4 related and not a failed HPFP.

I was able to set it to map 0 and flash the MHD stock 0 map to get home. Rail pressure seemed to instantly come back after this.

Once home, I unplugged the battery and verified/reseated all JB4 connections, flashed the latest JB4 FW and flashed the backend flash again.

Since then, things are running better, there are no *active* codes, however, there are some shadow codes and the trans seems to shifting slower and softer than before. When reading codes from the JB4 there are none. MHD shows the following shadow codes:

2DC5 torque requirement over CAN, plausibility
2FCA MHD had German error
2FDA MHD had German error
2FDB fuel pressure steuer ventil, plausibility

After clearing these codes only *shadow* 2DC5 came back.

I'm hoping to get some advise on what my next steps should be. Also, should I be seeing METH increment in the log? In addition to METH there are a few other things in the log that I think may be concerning. I am going to take it easy on the car until I get everything sorted.

My mods/maint include:
DCI
xHP stage 2
MHD backend "JB4_BB2_I8A0S_PUMP.bin"
VSRF D*P*s
JB4 G5 ISO FW "G5_ISO_32_10" Map 5 and Menu 4 set to 2
External PCV w/ ports plugged
New plugs/coils

Log from tonight

No datazap? okay I attached the log.

2018-03-20 21_40_52.csv
Reply With Quote
(#2)
Old
Kmastl Kmastl is offline
New Member
 
Posts: 13
Join Date: Aug 2017
Car: 2008 535i
Default 03-22-2018, 09:16 AM

Bump,

Some codes came back today, this appears to be the exact same behavior as prior to when the HPFP stopped running earlier this week.

Name:  Screenshot_20180322-081100.jpg
Views: 32
Size:  29.2 KB

Name:  Screenshot_20180322-081328.jpg
Views: 33
Size:  61.8 KB

Last edited by Kmastl; 03-22-2018 at 09:35 AM..
Reply With Quote
(#3)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,210
Join Date: Oct 2012
Car: 135i
Default 03-22-2018, 10:26 AM

JB4 will not cause an issue with the HPFP preventing the car to start.

*** codes...

http://www.n54tech.com/forums/showthread.php?t=47748



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#4)
Old
Kmastl Kmastl is offline
New Member
 
Posts: 13
Join Date: Aug 2017
Car: 2008 535i
Default 03-22-2018, 11:55 AM

Hey Steve,

My concern is not with the two active D*P codes.

I am concerned the shadow codes, HPFP not kicking on and soft shifting issue.

Are there adaptations that I should reset or certain params I should log?

The car was running without fault earlier this week prior to the JB4 being installed.

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
JB4 will not cause an issue with the HPFP preventing the car to start.

*** codes...

http://www.n54tech.com/forums/showthread.php?t=47748
Reply With Quote
(#5)
Old
Dave @ Fuel-it!'s Avatar
Dave @ Fuel-it! Dave @ Fuel-it! is offline
Legend
 
Posts: 1,240
Join Date: Apr 2014
Car: E92 335XI
Default 03-22-2018, 08:56 PM

Quote:
Originally Posted by Kmastl
Hey Steve,

My concern is not with the two active D*P codes.

I am concerned the shadow codes, HPFP not kicking on and soft shifting issue.

Are there adaptations that I should reset or certain params I should log?

The car was running without fault earlier this week prior to the JB4 being installed.
JB4 does not autoclear *** codes anymore- that will not cause any performance issues either.

Iím sure a custom BEF could get rid of those, but we canít / wonít



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Pure Turbos
TFT Inlet System
Fueling by Fuel-It!
Reply With Quote
(#6)
Old
Kmastl Kmastl is offline
New Member
 
Posts: 13
Join Date: Aug 2017
Car: 2008 535i
Default 03-25-2018, 03:19 PM

Update,

I removed the JB4, restored the stock DME tune from MHD (35 min process). Drove around with absolutely no issues.

I then re-installed the JB4, setting it to Map 0 and option 4/3. The soft shifting issue/code and HPFP codes came back.

Jon at BMS thinks it is a faulty control board.
Reply With Quote
(#7)
Old
Dave @ Fuel-it!'s Avatar
Dave @ Fuel-it! Dave @ Fuel-it! is offline
Legend
 
Posts: 1,240
Join Date: Apr 2014
Car: E92 335XI
Default 03-25-2018, 11:12 PM

Quote:
Originally Posted by Kmastl
Update,

I removed the JB4, restored the stock DME tune from MHD (35 min process). Drove around with absolutely no issues.

I then re-installed the JB4, setting it to Map 0 and option 4/3. The soft shifting issue/code and HPFP codes came back.

Jon at BMS thinks it is a faulty control board.
Did you flash the BEF again as well?

Wouldnít hurt to send in to Jon/bms to verify it isnít a board issue.



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Pure Turbos
TFT Inlet System
Fueling by Fuel-It!
Reply With Quote
(#8)
Old
Kmastl Kmastl is offline
New Member
 
Posts: 13
Join Date: Aug 2017
Car: 2008 535i
Default 03-26-2018, 04:51 AM

Nope,

I left stock tune for this test, I'm working on borrowing another JB4 to do the same test again. Theoretically the car should behave as if the JB4 is not there when on map 0.
Reply With Quote
(#9)
Old
Kmastl Kmastl is offline
New Member
 
Posts: 13
Join Date: Aug 2017
Car: 2008 535i
Default 04-20-2018, 08:05 PM

So I ordered a replacement JB4 circuit board and the exact same issue is happening.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2017, N54tech.com