N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default F10 535i Codes & Logs Review Please - 07-17-2017, 11:33 AM

Ran map 1 with the BMS intake and sprint booster for a few months on an e30 blend with no issues. Just installed a ******* ******** (for offroad use only of course) and MPE and switched to Map 2, did not touch the JB4 and was under the hood only to unplug and replug the O2 sensor wires. After about 20 miles of driving, I've had the following codes come up (also see attached). Car still drives like normal and the two logs attached are from before the codes popped up.

I understand I need to change the setting on my OBD II in dash menu 4 to "delete fault codes" to get rid of the CEL but before doing that I want to make sure that these codes are related to the ******* ******** or if I may have other issues?

I'd also like opinions on the logs with Map 2 on e30 blends.

Running N55_FSERIES_OBDII_PWG_11_T1 including FF connection and BT connect kit. FUA = 51 and FUD = 130 with only bit 1 and bit 7 enabled. No other changes to settings. Please let me know if you need any other info and thank in advance for any help!


Codes:
121002 MAP sensor, short to ground
119001 Rail sensor short circuit +
104402 MAP sensor short circuit -
102001 Air mass, plausibility -- Tuner code, ignore
101F01 Throttle valve opening angle pressure -- Ignore, tuner code
122108 BOV plausability -- Ignore, tuner code
213601 power management, closed-circuit protection: closed-circuit current violation
0000F1 No Description Found
Attached Images
File Type: pdf Fault Codes Pic.pdf (54.4 KB, 4 views)
Attached Files
File Type: csv 2017-07-16 17_04_23 (e30).csv (3.7 KB, 3 views)
File Type: csv 2017-07-16 18_03_34 (e30).csv (2.2 KB, 6 views)

Last edited by itzZshaan; 07-17-2017 at 12:35 PM..
Reply With Quote
(#2)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default 07-17-2017, 06:49 PM

Update - I changed menu 4 to delete fault codes and drove about 20 mins no problem. Re-read the codes from the app and only showed the following:

180001 ******* ******** detected
102001 Air mass, plausibility -- Tuner code, ignore

Needless to say no CEL on the dash as well which is nice, but still wondering if the codes thrown above were directly related to the **? I checked my MAP sensor and all looked fine. Thoughts...?
Reply With Quote
(#3)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 15,301
Join Date: Oct 2012
Car: 135i
Default 07-17-2017, 07:01 PM

I'd see if those return. If so, you'll need to verify your JB4 connections.

Where are you getting power for the JB4 from and where do you have power for the JB4 mobile connect kit installed?



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#4)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default 07-17-2017, 08:40 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
I'd see if those return. If so, you'll need to verify your JB4 connections.

Where are you getting power for the JB4 from and where do you have power for the JB4 mobile connect kit installed?
I'll definitely keep on eye on the codes, but just to confirm, I will no longer see the CEL pop up on the dash, correct? I'll just have to read codes from the mobile app every now and then to see what it's pulling?

As for the power connection, I have the jb4 powered by connecting to the 10mm nut under the black plastic cap per the instructions. However, I may switch the source to the thick red wire in the harness using a posi-tap per this post: http://www.n54tech.com/forums/showpo...33&postcount=4

And the mobile connect kit is powered by the red wire in the harness using the supplied posi-tap. Also FYI I've had the JB4 installed for about 275 miles running Map 1 before the codes from the first post came up this morning after installing the ** 2 day/50 miles ago.
Attached Images
   
Reply With Quote
(#5)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 15,301
Join Date: Oct 2012
Car: 135i
Default 07-18-2017, 09:04 AM

Okay, keep an eye out and see if the codes return. I'd definitely recommend changing the power to the switched source.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#6)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default 07-18-2017, 09:24 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Okay, keep an eye out and see if the codes return. I'd definitely recommend changing the power to the switched source.
Yup, just waiting for my posi-taps to come in on Thursday and will be switching to the switched source asap.

Also I meant to update this as soon as I got in the office but got tied up. The CEL popped up again on the dash on the drive in this morning and the additional code is:

122108 BOV plausibility -- Ignore, tuner code.

I wanted to include this here to keep track of the history but this isn't one of the original faults you want me to keep an eye out for right (I assume no since it says ignore)?

Did you have a chance to take a look at the logs btw? I'll see if I can get a couple more tonight but since the sample rate is slow, there aren't too many data points to review (but it may be enough for your professional opinion ).


2013 F10 535i M Sport - JB4, BMS Intake, VRSF D.P., SprintBooster v2, M Performance Exhaust, E30 fuel
Reply With Quote
(#7)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 15,301
Join Date: Oct 2012
Car: 135i
Default 07-18-2017, 09:26 AM

Correct...that is normal and can be ignored.

You'll need to resolve this issue and do better logs.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#8)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default 07-18-2017, 10:04 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Correct...that is normal and can be ignored.

You'll need to resolve this issue and do better logs.
Better logs coming soon! But to make sure I can get the most data possible, I will turn off "bit7 - Slow down CANbus sample rate - required for some vehicles with older software" unles you suggest otherwise. For some reason I thought this might help, but I think I got it confused with the EWG v11 update below, which I'm hoping was also an update for the PWG v11 firmware.

"By default cyl1 and cyl5 only are logged to speed up sample rate. Other cylinders are loggable via a FUD bit 6."


2013 F10 535i M Sport - JB4, BMS Intake, VRSF D.P., SprintBooster v2, M Performance Exhaust, E30 fuel
Reply With Quote
(#9)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default 07-18-2017, 07:47 PM

Alright did a few 3rd gear pulls 2k-7k rpm but something's off since the logs aren't picking up rpm and a lot of the parameters are static. Also I saw peak boost on the app at around 16 psi after each pull, but I'm not seeing that in the logs. Not sure if its a mobile app or BTMK or jb4 issue.

The last log is me just going through the gears at partial throttle which felt a lot better than the 3rd gear pulls. The 3rd gear WOT pulls didn't feel too great, like building boost, a surge of boost for a sec, then falling off again. I may try Map 5 tomorrow morning to see if I feel any difference and if I'm actually able to get logs with rpm, afr, etc.
Attached Files
File Type: csv 2017-07-18 19_35_07 (e30).csv (15.9 KB, 2 views)
File Type: csv 2017-07-18 19_40_04 (e30).csv (8.1 KB, 2 views)
File Type: csv 2017-07-18 19_41_42 (e30).csv (10.6 KB, 2 views)
File Type: csv 2017-07-18 19_45_28 (e30).csv (28.9 KB, 2 views)


2013 F10 535i M Sport - JB4, BMS Intake, VRSF D.P., SprintBooster v2, M Performance Exhaust, E30 fuel

Last edited by itzZshaan; 07-18-2017 at 07:54 PM..
Reply With Quote
(#10)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 15,301
Join Date: Oct 2012
Car: 135i
Default 07-18-2017, 08:45 PM

Nothing useful there.

What happens if you enable bit 7 and set FUA to 0?



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#11)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default 07-19-2017, 08:24 AM

Enabled bit 7 and set FUA to 0 and did three 3rd gear pulls... first two seem better, with the second pull capturing the most data. Don't know what's up with the third one.

Also the CEL keeps popping back up even after I enable menu 4. Should I not delete the codes from the app to keep the light off?
Attached Files
File Type: csv 2017-07-19 09_33_41 (e30).csv (3.3 KB, 1 views)
File Type: csv 2017-07-19 09_36_09 (e30).csv (11.2 KB, 2 views)
File Type: csv 2017-07-19 09_37_20 (e30).csv (6.5 KB, 3 views)


2013 F10 535i M Sport - JB4, BMS Intake, VRSF D.P., SprintBooster v2, M Performance Exhaust, E30 fuel
Reply With Quote
(#12)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 15,301
Join Date: Oct 2012
Car: 135i
Default 07-19-2017, 10:50 AM

That looks a lot better and the logs look normal.

For menu 4, see this update...

http://www.n54tech.com/forums/showthread.php?t=47748



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#13)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default 07-19-2017, 11:32 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
That looks a lot better and the logs look normal.

For menu 4, see this update...

http://www.n54tech.com/forums/showthread.php?t=47748
Ah, I missed that one.. it should be stickied!

Anyways thanks for reviewing the logs. Happy hear they're normal but any chance I can play with more than 14-16 psi of boost? Maybe try Map 5 or 7 or increase boost safety?


2013 F10 535i M Sport - JB4, BMS Intake, VRSF D.P., SprintBooster v2, M Performance Exhaust, E30 fuel
Reply With Quote
(#14)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 15,301
Join Date: Oct 2012
Car: 135i
Default 07-20-2017, 10:22 AM

You can certainly play with map 5 but we'll have to see what the logs look like on map 7. On E30 you should be okay as the stock turbo runs out of steam pretty quickly so boost drops off dramatically.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#15)
Old
itzZshaan itzZshaan is offline
New Member
 
Posts: 27
Join Date: Oct 2016
Car: F10 535i M-Sport
Default Yesterday, 08:38 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
You can certainly play with map 5 but we'll have to see what the logs look like on map 7. On E30 you should be okay as the stock turbo runs out of steam pretty quickly so boost drops off dramatically.
Map 7 logs for your review sir. The logs don't show it, but my peak boost after as shown in the app was 19.7 psi (but not sure if I hit that peak in the first or second pull). Car felt pretty good... your thoughts?
Attached Files
File Type: csv 2017-07-22 22_22_29 (e30).csv (3.5 KB, 2 views)
File Type: csv 2017-07-22 22_24_08 (e30).csv (8.0 KB, 2 views)


2013 F10 535i M Sport - JB4, BMS Intake, VRSF D.P., SprintBooster v2, M Performance Exhaust, E30 fuel
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2017, N54tech.com